Problème avec UScreenCapture

Logiciels (gratuits) liés au Replay, au multimédia, ...

Problème avec UScreenCapture

Messagede Babar2 » Mar 29 Déc 2020 11:42

Bonjour.

Bon, j'ai un peu de retard, j'ai mis 6 ans à tester VTCL sur une machine pour qui OBS Studio est trop gourmand notamment en CPU. Donc je télécharge, je lis le tutoriel et je configure pour une capture d'écran standard, pour tester quoi. Au lancement de la capture, j'ai un message comme quoi il y a une erreur et je dois entrer en "emergency mode" (tout le monde sur le pont), et donc je le fais et là ça m'ouvre une invite de commande avec le texte suivant :

Code: Tout sélectionner
ffmpeg version N-63439-g96470ca Copyright (c) 2000-2014 the FFmpeg developers
  built on May 25 2014 22:01:51 with gcc 4.8.2 (GCC)
  configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-avisynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enable-iconv --enable-libass --enable-libbluray --enable-libcaca --enable-libfreetype --enable-libgme --enable-libgsm --enable-libilbc --enable-libmodplug --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-librtmp --enable-libschroedinger --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libtwolame --enable-libvidstab --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxavs --enable-libxvid --enable-decklink --enable-zlib
  libavutil      52. 86.100 / 52. 86.100
  libavcodec     55. 65.100 / 55. 65.100
  libavformat    55. 41.100 / 55. 41.100
  libavdevice    55. 13.101 / 55. 13.101
  libavfilter     4.  5.100 /  4.  5.100
  libswscale      2.  6.100 /  2.  6.100
  libswresample   0. 19.100 /  0. 19.100
  libpostproc    52.  3.100 / 52.  3.100
[dshow @ 03336ee0] Could not find video device.
video=UScreenCapture:audio=Realtek HD Audio Input: Input/output error


Seules les deux dernières lignes me semblent pertinentes, mais je mets le reste, on ne sait jamais, j'ai regardé les options et je ne vois pas comment je peux régler ça, quelqu'un a une idée ? Pulsar33 peut-être ? Merci d'avance :)

Edit Pulsar33 : modification du titre
Avatar de l’utilisateur
Babar2
 
Messages: 1119
Inscription: Ven 26 Aoû 2011 11:53

Re: Problème avec UScreenCapture

Messagede Pulsar33 » Mar 29 Déc 2020 12:50

Bonjour,

Clic droit dans une zone vierge de la partie gauche => show capture devices => ?

VCTL Preferences => UScreenCapture parameters => ? (snapshot si possible)

Cordialement
Pulsar33

PS :
Comme indiqué maintes fois, ce mécanisme ne fonctionne pas sur toutes les structures HW malheureusement.
Mais ne perdons pas espoir trop vite


Ubuntu Linux 64 bits / France / Firefox 84.0
VCTL v2.0 pour vos traitements vidéos (à découvrir en lisant le Tutoriel).
Mes matériels : PCs MINT 19.3, XP SP3, Seven, 3 x Raspberry PI4, NAS Asustor, Disques Multimédia EMTEC, Tuner TNT TERRATEC, Camescope DV, Caméra 4KVR360
Avatar de l’utilisateur
Pulsar33
 
Messages: 2146
Inscription: Dim 30 Sep 2012 14:23
Localisation: Bordeaux

Re: Problème avec VTCL

Messagede Babar2 » Mar 29 Déc 2020 21:54

Bonsoir.

J'obtiens ceci pour les périphériques de capture.

Code: Tout sélectionner
[dshow @ 02b2dba0] DirectShow video devices
[dshow @ 02b2dba0]  "VGA WebCam"
[dshow @ 02b2dba0]  "OBS Virtual Camera"
[dshow @ 02b2dba0] DirectShow audio devices
[dshow @ 02b2dba0]  "Mixage st├®r├®o (Realtek(R) Audio)"


Donc il en reconnait mais il refuse de les utiliser ?
Avatar de l’utilisateur
Babar2
 
Messages: 1119
Inscription: Ven 26 Aoû 2011 11:53

Re: Problème avec UScreenCapture

Messagede Pulsar33 » Mar 29 Déc 2020 23:07

Bonjour,

Hum, soit tu n'as pas installé UScreenCapture soit il n'est pas reconnu par ta configuration.
Voici ce que j'avais :
Code: Tout sélectionner
C:\Outils\ffmpeg\bin>ffmpeg -list_devices true -f dshow -i dummy
[...]
    [dshow @ 02997a60] DirectShow video devices
    [dshow @ 02997a60]  "Philips PCVC750K Camera; Video"
    [dshow @ 02997a60]  "Corel Camera Plug-in"
    [dshow @ 02997a60]  "CorelScreenCapture"
    [dshow @ 02997a60]  "UScreenCapture"
    [dshow @ 02997a60] DirectShow audio devices
    [dshow @ 02997a60]  "VIA HD Audio Microphone"
    [dshow @ 02997a60]  "Appareil photo Philips PCVC750K"
    [dshow @ 02997a60]  "VIA HD Audio CD In"
    [dshow @ 02997a60]  "VIA HD Audio Front Microphone"
    [dshow @ 02997a60]  "VIA HD Audio Line In"
    [dshow @ 02997a60]  "VIA HD Audio Stereo Mixer"
    dummy: Immediate exit requested

Tu devrais avoir "UScreenCapture" dans les DirectShow video devices
Voir Tutoriel Page 1 en bas à gauche pour l'installation (ou ci-dessous) et Tutoriel Page 2 à droite pour l'initialisation et l'utilisation

Bonne journée
Pulsar33
VCTL v2.0 pour vos traitements vidéos (à découvrir en lisant le Tutoriel).
Mes matériels : PCs MINT 19.3, XP SP3, Seven, 3 x Raspberry PI4, NAS Asustor, Disques Multimédia EMTEC, Tuner TNT TERRATEC, Camescope DV, Caméra 4KVR360
Avatar de l’utilisateur
Pulsar33
 
Messages: 2146
Inscription: Dim 30 Sep 2012 14:23
Localisation: Bordeaux

Re: Problème avec UScreenCapture

Messagede Pulsar33 » Mer 30 Déc 2020 06:56

Re,

Je viens de faire un peu d'archéologie concernant UScreenCapture qui semble avoir évolué contre toute attente. Il faut croire que le besoin est bien réel.
Ce filtre directshow développé par Unreal Streaming Technologies ne disposait pas à l'époque d'interface graphique. C'est pourquoi je l'avais intégré dans VCTL.
Il semble en avoir une désormais ainsi qu'on peut le voir sur le site réputé VideoHelp. Je ne sais pas néanmoins quelles sont ses performances actuelles.
Par ailleurs, le titre des 3 tutos youtube semblent indiquer logiquement qu'il faut utiliser VLC, VirtualDub ou FFmpeg pour faire fonctionner le filtre, ce que fait VCTL (avec FFmpeg).

Pour une utilisation avec VCTL, il était conseillé d'utiliser une version 32 bits dans tous les cas et la version utilisée à l'époque était celle de 2013

Bon courage
Pulsar33


Ubuntu Linux 64 bits / France / Firefox 84.0
VCTL v2.0 pour vos traitements vidéos (à découvrir en lisant le Tutoriel).
Mes matériels : PCs MINT 19.3, XP SP3, Seven, 3 x Raspberry PI4, NAS Asustor, Disques Multimédia EMTEC, Tuner TNT TERRATEC, Camescope DV, Caméra 4KVR360
Avatar de l’utilisateur
Pulsar33
 
Messages: 2146
Inscription: Dim 30 Sep 2012 14:23
Localisation: Bordeaux


Retourner vers Autres logiciels

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 1 invité